Automatisms not working for profile and app distribution - Android Enterprise Devices

Hello Everyone!

I am enrolling Samsung Android devices with Android Enterprise in COPE mode, using the QRcode method and preparing the devices with a staging user.

  • First problem, I set an Application Control profile to blacklist apps in my personal profile, unfortunately it seems that the profile is not respected at the first installation, to make it is I have to go on the profile itself and force the installation on a given device. The assignment seems to be correct, unfortunately in the production phase the thing would become annoying if it remained so.
  • Second problem, when the employee enters his AD credentials for the final registration, I set that two apps are downloaded for the management of e-mail with parameters taken from the employee’s personal data. Also in this case the apps are not downloaded automatically as they should and if the downloads from the company store don’t have the preset parameters. If I force the installation again then everything works. But as before it becomes annoying during production with hundreds of devices.

Do things like this happen to you? I have to use staging because the customer wants the devices with the apps already downloaded, but I wonder if it’s not the staging itself that creates these problems?

Thanks and regards,



Seems a few people are having issues with staging users and AE.

  1. What platform and version are you using?
  2. Have you tried with a test user to verify if the issues relate to staging?

Hi Andrew,

  • I’m using the 2001 version platform (I tested it on 2004 and I have no problems, but I don’t manage updates and it doesn’t seem to be possible to update the platform in a short time)
  • the problem also arises when registering a user without going through staging

According to an analysis made by the platform providers, it is sufficient not to apply the blacklist rules until the apps have been distributed.
I tried this approach and it partially works, in staging apps are distributed in the corporate part and some apps in the private part (not all and I don’t understand why). But then when I enter the credentials of the end user, the last 2 apps (Outlook e Samsung Mail Client) are not distributed according to the set policies.

In my opinion there are obvious bugs on the 2001 version so that 2004 has deep changes in app assignment.